Signal Maps

Signal Maps are a way to visualize all of the data collected in the NEON Signal Mapper app. Signal Maps can show the intensity of various signals and the path where they were collected. The data can then be exported in various formats.

Open Signal Map

Signal Maps can be opened from a locally stored .sigmap or .sigmapx file or from the NEON Cloud. In order for a signal map to be available on the cloud, it must be uploaded from NEON Signal Mapper. See the Signal Mapper documentation for more information on saving signal maps.

To open a signal map on the cloud, click “File > Open > Cloud Signal Map”. Folders are named with the date of the signal maps and the files are named with the time they were uploaded as well as the name they were given at that time. Double click a file to open it, or select it and click “Open”.

Signal Maps - Cloud

To open a signal map stored locally, click “File > Open > File”, or press “Ctrl+O”. Select the appropriate file in its saved location and then click “Open”.

Signal Map Sidebar

The Signal Map sidebar shows all signals and signal types that were measured in the signal map. The signals that will be listed will only be of the type selected. To select a new signal type, click the dropdown menu at the top of the sidebar.

Signal Maps - Sidebar

Filter and Select

The signal filter allows users to search through all measured signals. Users can filter signals by typing the filter criteria just below the signal property name. Each signal type will display a different set of properties. The list below shows the properties that can be filtered and sorted for each signal type.

  • BLE - Name, MAC Address, Floor
  • WiFi [2.4GHz and 5.0GHz] - SSID, BSSID, Channel, Floor
  • GSM - Cell ID, Floor
  • CDMA - Base station ID, Network ID, System ID, Floor
  • WCDMA - PSC, Floor
  • LTE - Cell ID, Floor
  • DAQ - Floor
  • Channel Scanner (Anritsu) - Channel, Center, Span, BW, RLevel, Floor
  • SPA (Anritsu) - Measurement, Mode, Frequency, Direction, Floor
  • Viavi (Viavi) - Name, Mode, Direction, Floor
  • Tektronix (Tektronix) - Name, Floor

On the left of the sidebar, click the checkboxes to select signals. Click the “Select All” button beneath the signals list to select all of the signals in the current filter. Click the “Clear All” button to clear all checked signals.

Generate Heatmap

With at least one signal check, click the “Generate Map” button at the bottom right of the sidebar to generate a heatmap of the selected signals. Click “Clear Map” to remove the heatmap.

After generating a heatmap, the color map will automatically scale to fit the measured values. This can be disabled by unchecking the “Default” check box in the “Scale Settings” section of the sidebar. With the Default setting unchecked, change the values for “Min and Max” to set bounds on the color map. After changing these values, click “Generate Map” to view the updated colors.

Heatmap

Heatmaps are a cumulative display of signal measurements in an area. They will display the color of the strongest signal along a given segment of a user’s path. The heatmaps can be exported in various formats for distribution.

Users can configure heatmaps in a few ways: smoothing radius, opacity, and aggregation method. These can all be configured in the signal mapper preferences. The smoothing radius sets the display area for a particular signal measurement. Reduce the radius for more measurements to be shown in the heatmap. By default, the opacity is set to 50% at the measurement location. Heatmap opacity decreases further from the measurement location. The aggregation method determines if the heatmap is generated from the maximum, minimum, or average signal measurements.

Color Map

Heatmaps and colored dots will be displayed using the color map that the user has selected. Color maps can be changed by clicking “Edit > Color Maps”, then select the appropriate color map from the list, click “Set Default”, then click “Save”. See the documentation on custom color maps for more information.

Path

Signal Maps also display where users walked at any given time. Use the time bar at the bottom to control the time frame of a user’s path. This is covered in more detail in the track viewing documentation.

Export

Once a heatmap has been generated, it can be exported into various formats. These exports typically consist of a .zip file which includes .csv files and images that can be viewed without NEON Command. Complete documentation on this subject can be found in the report generation document.

Combine

Multiple signal maps can be combined into a single file in order to be viewed at the same time. Signal maps can be combined regardless of their time or location. While viewing the combined signal map, each combined file will appear simultaneously as its own avatar. Users can combine signal maps that are stored locally and on the cloud.

To combine signal maps, click “File > Open > Combined Signal Maps”. This will open a window which will show all of the signal maps being combined. To add local files, click the “Add Local” button and select the appropriate files from the computer. To add signal maps from the cloud, click “Add Cloud” and then check the box next to the appropriate signal maps.

Signal Maps - Combine Cloud

Once all of the signal maps have been added click “Open”. After a little bit of processing, the signal maps will open as a single file. This combined signal map can be used the same way as a standard single signal map.

Signal Maps - Combine

Grid Testing

Grid testing allows users to check if a building complies with NFPA building testing recommendation. With grid testing enabled, the floor plan will be overlaid with grids sized per the NFPA recommendation. The grids are colored green if they pass, red if they fail, gray if there are not enough signal readings, and transparent if the grid has never been visited.

To enable grid testing click “Edit > Preferences > Signal Mapper > Enable Grid Testing”. With grid testing enabled, a grid will be overlaid building floors when viewing a signal map. When a map is generated, it will not create a heatmap, but instead, the grid squares will fill in either green, red, or gray.

To configure the grid testing click “Edit > Preferences > Signal Mapper”. The available Grid Testing Options are:

  • Pass/Fail Threshold (dBm) - Sets the minimum required signal measurement (dBm) for a grid square to pass.
  • Measurements Required in Grid (dBm) - Sets the required number of signal measurements for a grid square to pass or fail.
  • Pass/Fail Threshold (DAQ) - Sets the minimum required DAQ measurement for a grid square to pass.
  • Measurements Required in Grid (DAQ) - Sets the required number of DAQ measurements for a grid square to pass or fail.