Offline Buildings

The Offline Buildings feature is a subscription feature which allows you to create a building that will never be uploaded to the NEON Cloud. An offline building can be exported from NEON Command and sideloaded on to an Android device for use in a NEON application. Any collected data associated with this building will not be uploaded to the NEON Cloud.

Offline Buildings must be enabled in your subscription by TRX Systems. If you would like to use Offline Buildings, please email support@trxsystems.com.

The following tutorial will explain how to use Offline Buildings. This tutorial can be used by both Signal Mapper and Personnel Tracker customers. Some sections may have a note that they apply to specific NEON applications and may not apply to your use case. In these cases, a link will be provided to the proper section.

Create an Offline Building

An Offline Building is created in much the same way as a private building. The only difference is that it is saved as “Offline” instead of “Private”. Follow these steps to create an offline building:

  1. Click “Tools > Create Building” to launch the building editor.
  2. Continue with the building creation as normal. Please see our Building Editor documentation for detailed information on how to do this.
  3. Make sure that your building is complete and accurate with all known floors, regions, and features. Making later edits will be time-consuming.
  4. Click “Save” in the building editor toolbox. A confirmation box will appear.
  5. Click “Yes” to confirm that you want to save your building and exit the editor. A new box will appear to select your building type.
  6. If it is not already selected, select “Offline” in the “Select Building Type” box.
  7. Click “OK” to save your building.

Offline Buildings - Save

Once a building has been saved as “Offline”, it cannot be made “Private”. Likewise, if a building has been saved as “Private”, it cannot be made “Offline”.

Export Your Offline Building

Now that your building is complete, it needs to be exported from NEON Command so that it can be loaded on to an Android device. To export your building:

  1. Select your “Offline Building” after you have saved it as “Offline”.
  2. Click “File > Export > Offline Mapping Package (Selected Building)”.
  3. In the “Save” dialog, choose a file path, and click “Save”. The building will be saved as a .maps file.

Offline Buildings - Export

After saving, a dialog box will pop up to list the contents of the building that were saved.

Load Your Offline Building on to other Computers

In the event that you are using multiple computers running NEON Command, you will need to import your building on the other computers. If you are only using one PC, please skip to the next section. Without importing your building, you will not be able to view any data taken in that building and things like Signal Maps will not render properly on other computers. Follow these steps to import your offline building on to other computers:

  1. Transfer a copy of your offline building .maps file to a USB drive that you can take to the other computers.
  2. Plug the USB drive into the new computer and launch NEON Command.
  3. Click “File > Import > Offline Mapping Package”.
  4. In the file browser, select your .maps file on your USB drive and click “Open”.

Offline Buildings - Import

Now that your offline building has been imported, you can remove the USB and repeat steps 2 through 4 for as many computers as you would like. You can also use any method you would prefer to transfer the .maps file to other computers.

Note: Any private buildings that overlap with your offline building will be hidden while the offline building is visible.

Load Your Offline Building on to Android

In order to be loaded on to Android, Offline Buildings require you to create a specific folder in the Android file system. Any Offline Buildings will be placed into this folder which the NEON applications will then load. To do this:

  1. Turn your Android device on and plug it into a Windows PC with USB.
  2. Set your phone to transfer files over USB. The process transferring files differs with various devices and Android versions. An option for this USB setting can typically be found in the notification tray, but check with your device manufacturer if you can’t find it.
  3. In the Windows File Explorer, open your Android device’s internal file system. The device should appear in the navigation panel on the left side of the window.
  4. Find the top level of file folders on the device. You should see other folders such as DCIM, Download, and Android.
  5. Select the “NEON” folder and then the “Maps” folder.
  6. Copy and paste your offline .maps file into this folder.
  7. After the file has transferred, you can disconnect your phone.

You will need to repeat these steps for all devices that will be using Offline Buildings.

Note: The NEON/Maps folder is automatically created the first time you login to Signal Mapper or Personnel Tracker.

Note: Any private buildings that overlap with your offline building will be hidden while the offline building is visible.

Offline Building

Signal Mapper Solution

This section only applies to NEON Signal Mapper. If you are using NEON Personnel Tracker, you can skip to that Personnel Tracker Solution section.

Now that your building has been loaded on to your phone it will show up when you open Signal Mapper. The building will be shown with a red outline. Signal mapping in your Offline Building will behave just like if it were private. The only difference is that when you stop signal mapping, you will not have the option to upload your log.

  1. Signal map as you normally would. See our Signal Mapper documentation for more information.
  2. Press the stop button to finish mapping.
  3. Choose the “Store Locally” option to save your signal map to your phone. You can add a name to your log if you would like.

Store Locally

Repeat these steps for as many signal maps as are needed.

Viewing Signal Map in NEON Command

Now that you have taken all of your signal maps, it is time to view them in NEON Command. To do this, you will need to download them from your Android device on to your computer, then they can be open as a local file in NEON Command.

  1. Plug your Android device into your computer via USB.
  2. Set your phone to transfer files over USB.
  3. In the Windows File Explorer, open your Android device’s internal file system and navigate to the “NEON” folder.
  4. Find the “SignalMaps” folder and open it. Here you will find all signal maps that were stored locally.
  5. Select and copy the .signal files that you just created. Paste them on to your computer in the location of your choosing. Any pictures taken during your mapping will also need to be copied.
  6. Open NEON Command and click “File > Open > File (or press Crtl+O)”.
  7. In the file browser, select the file you just saved and click “Open”.
  8. You can now review your signal map as needed. See the signal map documentation for more information.

Offline Buildings - Open Signal Map

Personnel Tracker Solution

This section only applies to NEON Personnel Tracker. If you are using NEON Signal Mapper, you can jump to the Signal Mapper section.

Now that your building has been loaded on to your phone it will show up when you open Personnel Tracker. The building will be shown with a red outline. Your Offline Building can be mapped in Mapper Mode and then loaded on to multiple other devices running Personnel Tracker.

Mapper Mode

You can use Mapper Mode to create .maps files that will be used in conjunction with your Offline Building. You can run Mapper Mode on just one phone and then load them on to as many phones as you would like.

  1. Map your offline building as you would normally. See our Mapper Mode documentation for more information.
  2. Press the “Stop” button to finish mapping.
  3. Choose the “Store Locally” option to save your mapping data to your phone.

Store Locally

You can repeat these steps as many times as you would like in order to fully map your building. Once you are satisfied, you will need to save all of this data on your computer for distribution to other devices. If you will be using Personnel Tracker only on your current device, then you can skip the following steps. Otherwise, continue with the following:

  1. Plug your Android device into your computer via USB.
  2. Set your device to transfer files over USB.
  3. In the Windows File Explorer, open your Android device’s internal file system. Navigate to the “NEON” folder and then open the “Maps” folder.
  4. Copy all of the files in the “Maps” folder. Paste them on to your computer in the location of your choosing.
  5. Disconnect your Android device.

Now that all of your mapped data is saved on your computer, it can be loaded on every device that will be running Personnel Tracker.

Personnel Tracker

When tracking any number of people, it is important to make sure they are all using the same information. Gather up your Android devices and do the following:

  1. Connect an Android device to your computer via USB.
  2. Set your device to transfer files over USB.
  3. Navigate to the “NEON” folder and then open the “Maps” folder. If the folders do not exist on this device, create it.
  4. Copy all of the .maps files you previously copied to the PC and paste them into this folder.
  5. Disconnect your Android device.

Repeat these steps for as many devices as needed. Now when these devices run Personnel Tracker, they will all be using the same building models, features, and references. With all of your devices ready, you can run them with Personnel Tracker as many times as you would like.